В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Решить (vba) 1. написать программу вычисления стоимости поездки на автомобиле на дачу (туда и обратно). исходными данными являются: расстояние до дачи (в километрах); количество бензина, которое потребляет автомобиль на 100 км пробега; цена одного литра бензина. 2. написать программу пересчета веса из фунтов в килограммы (1 фунт равен 409,5 г). 3. написать программу конвертер величин: с клавиатуры вводиться вес информации в байтах. на выходе получаем перевод величины в: • биты , килобайты, мегабайты, гигабайты 1байт = 8 бит 1кб (килобайт) = 1024 байт 1мб (мегабайт) = 1024 кб 1гб (гигабайт) = 1024 мб 1тб (терабайт) = 1024 гб

Ответ:
ynavuhlitska
ynavuhlitska
04.10.2020 07:34
Program aaa;
var
  s, b, l, c: real;
begin
  writeln('введите s, b, l');
  readln(s, b, l);
  c := b / 100 * s * 2 * l;
  writeln('стоимость поездки: ', c)
end.

program aaa;
{Написать программу пересчета веса из фунтов (f) в килограммы (kg)
(1 фунт равен 409,5 г).} 
var
  f,kg: real;
begin
  writeln('введите f');
  readln(f);
  kg:=f*409.5/1000;
  writeln(f,' фунтов = ', kg:8:3,' килограмм')
end.

program aaa;
{Написать программу Конвертер величин: 
с клавиатуры вводиться вес информации в байтах (b). 
На выходе получаем перевод величины в: биты (bi) , килобайты (kb),
Мегабайты (mb), гигабайты (gb).
1байт = 8 бит
1Кб (килобайт) = 1024 байт
1Мб (мегабайт) = 1024 Кб
1Гб (гигабайт) = 1024 Мб
1Тб (терабайт) = 1024 Гб} 
var
  b,bi,kb: real; mb,gb,tb: decimal;
begin
  writeln('введите b');
  readln(b);
  bi:=b*8;
  kb:=b/1024;
  mb:=kb/1024;
  gb:=mb/1024;
  tb:=gb/1024;
  writeln(b,' байт = ', bi,' бит');
  writeln(b,' байт = ', kb,' килобайт');
  writeln(b,' байт = ', mb,' мегабайт');
  writeln(b,' байт = ', gb,' гигабайт');
  writeln(b,' байт = ', tb,' терабайт')
end.
//формат вывода (к-во знаков ...) определите сами
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?