В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Тер32
Тер32
20.11.2021 22:28 •  Информатика

Написать программу вхождения каждого символа в текст, содержащийся в файле в формате txt, на языке программирования высокого уровня basic (можно либо на qbasic или на visual basic)?

Ответ:
DIlyus
DIlyus
07.07.2020 22:50
Const
  T = '';
  n = 66;//  Количество символов в Т

var
  s,buf: string;
  P: array[1..n] of integer;
  i, k: integer;
  F: Text;

begin
  Assign(F, 'CharCount.txt');
  Reset(F);
  s:='';
  while not SeekEof(F) do begin
    Read(F,buf);
    s:=s+buf
  end;
  Writeln(s);
  for i := 1 to n do P[i] := 0;
  for i := 1 to length(s) do
  begin
    k := Pos(s[i], T);
    if k > 0 then P[k] := P[k] + 1
  end;
  for i := 1 to n do
    if P[i] > 0 then writeln(T[i], ' - ', P[i]:3)
end.

Тестовый пример:
Ксаверий Феофалактович Грушин, следственный пристав Сыскного управления при московском обер-полицмейстере,облегченно вздохнул и отложил влево, в стопку "просмотрено", сводку важных преступлений за вчерашний день
Г -   1
К -   1
С -   1
Ф -   1
а -   8
б -   2
в -  13
г -   2
д -   4
е -  17
ж -   2
х -   2
и -  11
й -   5
к -   6
л -  10
м -   4
н -  13
о -  20
п -   8
р -  11
с -  12
т -   8
у -   6
ф -   1
ц -   1
ч -   3
ш -   2
ы -   3
ь -   1
я -   1
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?