В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Составить программу начисления стипендии группе студентов из 25 человек по итогам сессии из 5 экзаменов. стипендия в размере 900 рублей начисляется студенту, не имеющему троек. посчитать сумму, необходимую для выплаты стипендии и вывести список студентов, получающий стипендию.

Ответ:
Liova23
Liova23
07.07.2020 14:48
Program Stipendiya;
type
Student = record
Ocenka: array [1..5] of Byte;
end;
var
i, j: Byte;
Summa: Integer;
Troechik: Boolean;
Studenti: array [1..25] of Student;
begin
for i:=1 to 25 do
begin
// Zapolnyaem ocenki studentov:
WriteLn('Vvedite ocenki '+IntToStr(i)+' studenta: ');
for j:=1 to 5 do
begin
Write('Ocenka za '+IntToStr(i)+' ekzamen: ');
ReadLn(Studenti[i].Ocenka[j]);
end;
end;

// Chitaem summu

S:=0;

WriteLn('');

for i:=1 to 25 do
begin
//
Troechik:=False;
//
for j:=1 to 5 do
if Studenti[i].Ocenka[j] < 4 then Troechik:=True;
//
if not Troechik then
begin
WriteLn('Vidat stipendiu '+IntToStr(i)+' studentu');
Summa:=Summa + 900;
end;
end;

// Vivod summi vsex stipendii
WriteLn('Summa vsex stipendii = '+IntToStr(Summa));
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?