В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
lilichka0109
lilichka0109
08.03.2021 07:08 •  Информатика

С1. составить алгоритм и написать программу на вычисление площади или периметра прямоугольника , при условии, если а < b , тогда вычисляем периметр , иначе площадь . каждую строку программы прокомментировать . входные данные а=10 , b=8 решить 9 класс

Ответ:
RUMBANITTA
RUMBANITTA
07.07.2020 12:52
Более красивый вариант) 

Program N_1;                         //Название программы
Var a,b,c:integer;                   //Переменные
BEGIN
Writeln('Введите длину и ширину прямоугольника');  //Вывести данную строку
readln(a,b);                         //Считать a и b
if a<b                                 //Если a<b
then begin                          //то найти периметр
c:=(a+b)*2;
Writeln('Пириметр= ',c)       //и вывести его
end
else begin                         //Если a>b
c:=a*b;                             //то найти площадь
writeln('Площадь= ',c)       //и вывести ее.
end;
END.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?