В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
morgacheva2001
morgacheva2001
06.06.2023 15:54 •  Информатика

Тема: массивы ! написать программу расчета среднего арифметического отрицательных элементов в одномерном массиве. заменить минимальный элемент в одномерном массиве на полученное среднее арифметическое.

Ответ:
Анютка1456
Анютка1456
07.07.2020 06:54
Var
  i,n:integer;
  s,min:real;a:array[1..10]of real;
begin
writeln('Исходный массив:');
for i:=1 to 10 do
  begin
  a[i]:=random(-10,10);
  write(a[i],' ');
  if a[i]<0 then
     begin
     s:=s+a[i];
     n:=n+1;
     end;
  if a[i]<min then min:=a[i];
  end;
writeln;
s:=s/n;
for i:=1 to 10 do  if a[i]=min then a[i]:=s;
writeln('Среднее отрицательных:',s);
writeln('Измененный массив:');
for i:=1 to 10 do  write(a[i],' ');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?