В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Составьте программу осуществляющую поиск однофамильцев, обучающихся в одном классе

Ответ:
Kakashka2001
Kakashka2001
01.10.2020 21:14
uses crt;
type uchenik=record            
 fam:string[20];            
 im:string[20];            
 kls:string[3];              
end;
var a:array[1..100] of uchenik;    
n,i,j,k:byte;
begin
clrscr;
writeln('Сколько учеников n=');
readln(n);
writeln('Введите данные о ',n,' учениках:');
for i:=1 to n do
 begin   writeln('Ученик ',i);  
write(' Фамилия: ');
readln(a[i].fam);  
write(' Имя: ');
readln(a[i].im);  
write(' Класс ( год+буква, 11а): ');
readln(a[i].kls);  
end;
writeln('Однофамильцы в одном классе:');
k:=0; for i:=1 to n-1 do for j:=i+1 to n do
if (a[i].fam=a[j].fam)and(a[i].kls=a[j].kls) then  
begin  
 k:=1;  
writeln(a[i].kls,'  ',a[i].fam,'  ',a[i].im,'  ',a[j].fam,'  ',a[j].im);  
end;
if k=0 then write('Однофамильцев в одном классе нет!');
readln
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?