Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
ExLuSsiVe
22.12.2020 02:21 •
Информатика
Написать программы 1. дано целое число n (> 0). если n — нечетное, то вывести произведение 1•3••n; если n — четное, то вывести произведение 2•4••n. 2. вывести на экран таблицу значений функции x2 на отрезке[0,1] с шагом 0.1.
Ответ:
aptyp4ik228
01.10.2020 21:05
1.
#include <iostream>
using namespace std;
int main()
{
int i,j,a,b,n;
cin >> n;
a=1;
if (n % 2 == 1) {
for (i=1;i<=n;){
a=a*i;
i=i+2;
}}
else {
for (i=2;i<=n;){
a*=i;
i+=2;
}
}
cout << a;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
оуовлвдсл
29.03.2021 11:18
Дано двузначное число верно ли что все цифры этого числа одинаковые. решите в...
pykanchik
07.06.2021 03:46
Как цвета многоцветных изображений?...
Министрелия2222
07.06.2021 03:46
Решить на программирование паскаль: четвероклассник петя сложил из карточек с прописными буквами слово. оставшиеся карточки с буквами он убрал в ящик стола. перед приходом из школы...
Rostislav200353
22.06.2020 10:17
Минимальное число в последовательности положительных чисел.pascal abc...
super12345167
22.06.2020 10:17
1.составить таблицы сложения и умножения в двоичной системе счисления и выполнить вычисления: а) 1110 + 101; б) 10101 - 11; в) 101 * 11; г) 1110 / 10. 2. представить числа в двоичном...
tvoibati00
22.06.2020 10:17
6. даны целые числа а и b. написать программу,которая подсчитывает среди них меньше нуля....
asia1406
03.01.2020 23:31
Почему тактильную информацию нельзя передать через интернет...
АндрейЯсийчук
14.11.2021 22:50
Задан следующий массив arr некоторого типа type (type занимает n байт в памяти) type arr[14][5][2][7]; требуется определить разницу в байтах между следующими адресами (если это...
OМайгад
07.03.2020 07:25
Имя компьютера в сети: какое оно бывает их различия из чего состоят...
маша111221
16.02.2021 19:00
Даны целые числа a, b, c. если a ≤ b ≤ c, то все числа заменить rкубами, если a b c, то смените знак каждого числа, в противном случае каждое число заменить наибольшим и них....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
#include <iostream>
using namespace std;
int main()
{
int i,j,a,b,n;
cin >> n;
a=1;
if (n % 2 == 1) {
for (i=1;i<=n;){
a=a*i;
i=i+2;
}}
else {
for (i=2;i<=n;){
a*=i;
i+=2;
}
}
cout << a;
}