В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
chipssensey
chipssensey
01.06.2020 03:00 •  Информатика

Составить программу (turbo pascal) вычисления величины дохода по вкладу. процентная ставка (в процентах годовых) и время хранения (в днях) во время работы программы. ниже представлен рекомендуемый вид диалога во время работы программы. данные, вводимые пользователем, выделены жирным шрифтом. величина вклада (р.) - 25000 срок вклада (дней) - 30 годовая процентная ставка (%) - 12 доход: 252 р. 80 коп. сумма по окончании срока вклада: 25252 р. 80 коп.

Ответ:
8007F300среднячок
8007F300среднячок
01.10.2020 20:50
Я не экономист и не экстрасенс, так что если именно сама формула подсчета дохода неверна - меняйте сами, я ее просто нашла в интернете.

var
vklad, dohod, summa, stavka: real;
srok: integer;
begin
write('Величина вклада (р.) - ');
readln(vklad);
write('Срок вклада (дней) - ');
readln(srok);
write('Годовая процентная ставка (%) - ');
readln(stavka);
dohod := (vklad*stavka)/(100*365) * srok;
summa := vklad + dohod;
writeln('Доход: ', Trunc(dohod), ' р.', frac(dohod)*100:3:0, ' коп.');
writeln('Сумма по окончании срока вклада: ', Trunc(summa), ' р.', Frac(summa)*100:3:0, ' коп.');
end.
0,0(0 оценок)
Ответ:
СинийГраф
СинийГраф
01.10.2020 20:50
{pascal, консольный ввод}

var
    velichina_vklada, srok_vklada, godovaya_procentnaya_stavka: integer;
    vklad_s_procentami: real;
   
    vklad_s_procentami_rub, vklad_s_procentami_kop: integer;
    dohod_rub, dohod_kop: integer;
   
begin
    write('Величина вклада (р.) - ');
    readln();
    write('Срок вклада (дней) - ');
    readln(srok_vklada);
    write('Годовая процентная ставка (%) - ');
    readln(godovaya_procentnaya_stavka);
   
    vklad_s_procentami := velichina_vklada * ((real(100) + real(godovaya_procentnaya_stavka)*real(srok_vklada)/365)/100);
    dohod_rub := (velichina_vklada - integer(vklad_s_procentami));
    dohod_kop := (velichina_vklada*100 - integer(vklad_s_procentami*100)) mod 100;
   
    vklad_s_procentami_rub := integer(vklad_s_procentami);
    vklad_s_procentami_kop := integer((vklad_s_procentami*100)) mod 100;
   
    writeln('Доход: ', dohod_rub,' р. ', dohod_kop, ' 80 коп.');
    writeln('Сумма по окончании срока вклада: ', vklad_s_procentami_rub, ' р. ', vklad_s_procentami_kop, ' коп.');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?