В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
StasSav06
StasSav06
17.01.2020 17:25 •  Информатика

30 напишите программу, которая в последовательности натуральных чисел определяет количество самых больших чисел в последовательности. программа получает на вход количество чисел в последовательности, а затем сами числа. количество чисел не превышает 100 введённые числа по модулю не превышают 300 программа должна вывести одно число: количество самых больших чисел в последовательности. пример работы программы: входные данные 5 выходные данные 2 15 27 24 12 27

Ответ:
helpistupit
helpistupit
25.05.2020 05:31

Pascal:

var a,n,count,max,i:integer;

begin

count :=0;

max:= -1;

readln(n);

for i:=1 to n do

     begin

     readln(a);

 if (a>max) then

        begin

        max:=a;

  count:=1;

  end

 else

         begin

         if (a = max) then

        count:=count+1;

  end

     end;

writeln(count);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?