В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
nikoldasha421
nikoldasha421
01.03.2021 14:54 •  Информатика

Вpascal abc составить программу для подсчета четных цифр, используемых для записи произвольного числа x. использовать цикл с предусловием, другого не проходили !

Ответ:
lilia104
lilia104
06.07.2020 17:58
Program red;
var a,b:integer;
begin
b:=0;
readln(a);
if a<10 then
begin
if a mod 2=0 then b:=1;
end;
if (a>=10) and (a<100) then
begin
if ((a div 10) mod 2=0) and (a div 10 <>0) then b:=b+1;
if ((a mod 10) mod 2=0) and (a mod 10 <>0) then b:=b+1;
end;
if (a>=100) and (a<1000) then
begin
if ((a div 100) mod 2=0) and (a div 100 <>0) then b:=b+1;
if (((a div 10) mod 10) mod 2=0) and ((a div 10) mod 10 <>0) then b:=b+1;
if ((a mod 10) mod 2=0) and (a mod 10<>0) then b:=b+1;
end;
writeln(b);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?