В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
galaxykill
galaxykill
16.12.2021 13:37 •  Информатика

Составить программу, решающую следующую : возраст коли – x лет, а возраст миши – y лет. найти их средний возраст, а также определить, на сколько возраст одного мальчика отличается от возраста другого.

Ответ:
27Alisa371
27Alisa371
06.07.2020 12:04
#include <iostream>

using namespace std;
int main(){
int a,s,d,f;
setlocale(0,"");
cout<<endl<<"Введите возраст Коли:";
cin>>a;
cout<<endl<<"Введите возраст Миши:";
cin>>s;
if (a>s && a>0 && s>0) {
d=a-s; f=(a+s)/2;
cout<<endl<<"Коля старше Миши на: "<<d<<" лет"<<endl;
cout<<"Средний возраст ребят: "<<f<<" лет"<<endl;
}
if (a<s && a>0 && s>0) {
d=s-a; f=(a+s)/2;
cout<<endl<<"Миша старше Коли на: "<<d<<" лет"<<endl;
cout<<endl<<"Средний возраст ребят: "<<f<<" лет"<<endl;
}
if (a<0 || s<0) {
cout<<endl<<"Вы ввели отрицательное число"<<endl;
}
system ("pause");
return 0;}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?