В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
jumadillaeva
jumadillaeva
02.12.2021 18:42 •  Информатика

Написать программу в паскале и подробно описать присвойте z значение большего из x и y в том случае если x< 0 и меньшего если x> =0

Ответ:
averianova1986
averianova1986
06.07.2020 11:27
Var x,y,z:integer; {описание переменных и их типа}
begin
writeln ('введи два числа'); {Вывод на экран сообщения-подсказки}
readln (x,y); {считывание переменных}
if x<0 then                      {проверка условия.}
  if y>x then z:=y             {если условие истинно, то мы ищем большее из х и у. если                                        у больше, то присваиваем z значение у}
           else z:=x             {если же больше х, то присваиваем его значение}
        else                        {если условие ложно}
           if y>x then z:=x     {то мы ищем меньшее из х и у. если                                                                           у больше, то присваиваем z значение х}
                    else z:=y;     {если же больше х, то присваиваем значение у}
writeln (z);                        {вывод результата на экран}
end.                                 {конец программы}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?