В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
69supreme
69supreme
17.02.2020 23:53 •  Информатика

Составить программу, которая упорядочивает элементы четных строк по возрастанию,а нечетных по убыванию.матрица размером 8х8.полученную матрицу напечатать.

Ответ:
Авитя1
Авитя1
05.07.2020 22:53
Var
   i,j,k,p:integer;
   a:array[1..8,1..8]of integer;
begin
writeln('Исходный массив:');
for i:=1 to 8 do
begin 
for j:=1 to 8 do
    begin   
    a[i,j]:=random(20);
    write(a[i,j]:3)
    end;
    writeln
end;
for i:= 1 to 8 do
     for j:= 1 to 8 do
     for k:= 1 to 8 do
        begin
        if i mod 2=0 then
           begin
           if (a[i,j]<a[i,k]) then
              begin
              p:=a[i,j];
              a[i,j] := a[i,k];
              a[i,k] := p
              end
           end
           else
              if a[i,j] > a[i,k] then
                 begin
                 p:=a[i,j];
                 a[i,j] := a[i,k];
                 a[i,k] := p
                 end
       end;
writeln('Преобразованный массив:');
for i:=1 to 8 do
   begin
   for j:=1 to 8 do
      write(a[i,j]:3);
   writeln
   end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?