Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
Милана11347
11.05.2020 11:56 •
Информатика
Написать программу, которая формирует одномерный массив(массив температур) ,вычисляет среднее арифметическое положительных элементов массива m[1..30]
Ответ:
svetamax70
06.07.2020 08:40
Var a:array[1..30] of integer;
i,sr,k:integer;
begin
for i:=1 to 30 do begin
read(a[i]);
if a[i]>0 then begin sr+=a[i]; inc(k); end;
end;
writeln(sr/k:3:2);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
жорж78
08.05.2020 03:30
Дадим 30 в программе кумир в чертежнике набрать слово мир. , зарание .! если что то непонятно то напишите в коментариях...
kuanyshbek2003
01.01.2021 04:50
Пк не будет функционировать. если отключить...
renata82
01.01.2021 04:50
Написать программу алгоритма поисков и сортировки для массива...
vetoss2
01.01.2021 04:50
Написать программу в паскале! найти сумму 2^2 +2^3 + . операцию возведения в степень не исполь- зовать. последовательность фибоначчи образуется так: первый и второй члены по-...
Karolinka22
03.03.2020 15:02
Найти количество файлов размером 240 кб которые можно записать на диск 32мб...
kirill13125a
07.04.2022 08:34
Вкаком режиме нельзя менять содержимое слайдов? 1. страницы заметок 2. обычный 3. показ слайдов 4. сортировщик слайдов...
ПолинаSweet11
07.04.2022 08:34
Придумайте сложный пример, в котором ответ будет = 14...
МиленаКриницына
02.08.2022 01:36
Попытка 2. может кому не сложно дано двумерный массив который скадаеться с 5 строк и 8 столбцов, который вычисляется по формуле cosij + sinij. вывести массив на экран, а также...
Teoman1Oztemel
30.06.2020 13:22
Дан двумерный массив. заменить все элементы 5 столбца на 2. кумир...
bulyginanastya
10.04.2022 23:52
Носитель информации, с которого происходит обмен информацией между частями компьютера - это a)шина b)разъём c)проводник d)интерфейс....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
i,sr,k:integer;
begin
for i:=1 to 30 do begin
read(a[i]);
if a[i]>0 then begin sr+=a[i]; inc(k); end;
end;
writeln(sr/k:3:2);
end.