В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
renata82
renata82
01.01.2021 04:50 •  Информатика

Написать программу алгоритма поисков и сортировки для массива

Ответ:
madisha12
madisha12
08.10.2020 17:32
    const n=10;
    var
      a:array[1..n] of real;
      i:integer;
      k:real;
    begin
      write('введите ',n,' элементов массива:');
      for i:=1 to n do read(a[i]);
        i:=1;
        while i<n do
            if a[i + 1]<a[i] then begin
              k:=a[i];
              a[i]:=a[i+1];
              a[i+1]:=k;
                i:=1;
             end
            else i:= i+1;
      write('отсортированный массив:');
      for i:=1 to n do write(a[i]:8:2);
    end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?