Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
даниил851
28.09.2021 01:10 •
Информатика
Написать программу на языке паскаль (разветвляющийся алгоритм): 1) f=x2-3 (икс в квадрате минус три), x2=x*x (x в квадрате равен x умножить на x) 2) s=1/2ab (одна вторая а б) 3) с=a2-b2 (а в квадрате минус б в квадрате)
Ответ:
ingamelnik99
05.07.2020 13:53
Var x,f,s,c,a,b:real;
begin
write('X = ');
readln(x);
write('A = ');
readln(a);
write('B = ');
readln(b);
f:=x*x-3;
s:=a*b/2;
c:=a*a-b*b;
writeln('F=',f:3:2,' S=',s:3:2,' C=',c:3:2);
end.
0,0
(0 оценок)
Ответ:
kozlovaangelina
05.07.2020 13:53
1) Не разветвление)
program xizt;
uses crt;
var x,f:real;
begin
writeln ('введите х');
readln (x);
f:=sqr(x)-3;
writeln (f);
end.
2) program xizt;
uses crt;
var a,b,s:real;
begin
writeln ('введите a,b через пробел');
readln (a,b);
s:=1/2*a*b
writeln (s);
end.
3) program xizt;
uses crt;
var a,b,c:real;
begin
writeln ('введите a,b через');
readln (a,b);
c:=sqr(a)-sqr(b);
writeln (c);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
кент1346
26.01.2022 08:51
Написать программу : из трех данных чисел ( a , d и с) найьи максимальное и умньшить его на 5...
AnastasyaOrlyanskaya
26.01.2022 08:51
Смассивами в массиве 20 случайных чисел. найдите и выведите на экран максимальное из них....
leraklybnika
31.08.2021 02:49
Как изменить цвет шрифта выделенной части текста...
Pro100iraa
09.09.2021 23:06
Перечислите виды условий ...
ИльяК2806
08.01.2021 06:49
Изучи предложенный алгоритм и определи недостающий анимационный эффект В «Области анимации».область анимацииПросмотр1 * Picture 22XELPHRGO 1.wav3* Wildfe.wmv4 улыбающеес......
kasper121314
10.07.2021 04:05
Надо сгенерировать 3 рандомных чисел.если эти три числа будет делится на 3 надо поставить ок а если эти три числа не будет делится на 3 тогда поставим no ok.зделать...
BULATKA177
15.06.2021 04:37
Сделать программы в vba ! 2. дано целое число. если оно нечетное, то вычислить сумму синуса и косинуса этого числа, в противном случае вычислить модуль этого числа....
yana07072005
22.10.2022 08:46
:1.выберите : 1.выберите из списка название рек,которые протекали по территории государства в x веке: а)десна,б)волга,в)лена,г)обь,д)днепр,е)кама,ж)двина 2.расположите...
alina2000klimenko
22.10.2022 08:46
Решите неравенство 2(х-4)(х+5) 0...
Ртдотк
22.10.2022 08:46
Периметр квадрата дорівнює 128 см.яка довжина його сторони?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
begin
write('X = ');
readln(x);
write('A = ');
readln(a);
write('B = ');
readln(b);
f:=x*x-3;
s:=a*b/2;
c:=a*a-b*b;
writeln('F=',f:3:2,' S=',s:3:2,' C=',c:3:2);
end.
program xizt;
uses crt;
var x,f:real;
begin
writeln ('введите х');
readln (x);
f:=sqr(x)-3;
writeln (f);
end.
2) program xizt;
uses crt;
var a,b,s:real;
begin
writeln ('введите a,b через пробел');
readln (a,b);
s:=1/2*a*b
writeln (s);
end.
3) program xizt;
uses crt;
var a,b,c:real;
begin
writeln ('введите a,b через');
readln (a,b);
c:=sqr(a)-sqr(b);
writeln (c);
end.