В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Arsen00628
Arsen00628
01.04.2023 17:31 •  Информатика

Составить программу ,находящую кол-во и сумму цифр пяти данных целых чисел ,используя процедуру

Ответ:
Zarxis
Zarxis
05.07.2020 12:13
Var i,x,k,s:integer;

function Sum(x:integer):integer;
var
   t:string;
   i:integer;
begin
s:=0;
t:=IntToStr(x);
for i:=1 to length(t) do s:=s+StrToInt(t[i]);
result:=s
end;

function Kol(x:integer):integer;
var t:string;
begin
t:=IntToStr(x);
result:=length(t)
end;

begin
for i:=1 to 5 do
  begin
  write('Введите число ',i,': '); 
  readln(x); 
  k:=Kol(x); 
  s:=Sum(x); 
  writeln('Количество цифр ',k,'; сумма цифр ',s)
  end
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?