В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Составить программу на паскале.вычислить корни квадратного уравнения, заданного коэффициентами a, b, c (предполагается, что а< > 0 и что дискриминант уравнения неотрицателен)

Ответ:
данна16
данна16
05.07.2020 11:27
Var   a,b,c,D,x1,x2:real;
begin
write('Введите коэффициенты a, b, c: ' );
readln(a,b,c);
D:= b*b-4*a*c; 
if D>0 then 
   begin
   x1:=(-b-sqrt(D))/2/a;
   x2:=(-b+sqrt(D))/2/a;
   writeln('Два корня: ',x1,' и ',x2)
   end;
if D=0 then
   begin
   x1:=-b/2/a;
   writeln('Один корень: ',x1)
   end;
if D<0 then writeln('Корней нет')
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?