Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Ф
Физика
Э
Экономика
М
Математика
Г
География
И
Информатика
Ф
Французский язык
М
МХК
О
Окружающий мир
Н
Немецкий язык
П
Психология
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
А
Английский язык
Б
Биология
Қ
Қазақ тiлi
Показать больше
Показать меньше
fedun20042004
15.11.2021 06:19 •
Информатика
Дан массив x(n). найти произведение тех элементов массива значения которых заключены в интервале [а,в] и кратны 3 или 5
Ответ:
666656
05.07.2020 11:15
A:array[1..10000] of integer;
i, n, a, b, k:integer;
begin
k:=1;
readln(n, a, b);
for i:=1 to n do
readln(a[i]);
for i:=a to b do
if ((a[i] mod 3)=0) or ((a[i] mod 5)=0) then k:=k*a[i];
writeln(k);
readln;
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
JugerHangerKrag
25.10.2022 13:55
Вывести на экран четные элементы массива; рассчитать и вывести их произведение.! 40 !...
VasyaKotikSnake
25.10.2022 13:55
Какие блоки ты уже знаешь и для чего они предназначена...
4EJLOBEK228
10.10.2021 02:09
Предложите последовательность рисования следующего объекта пуговица...
missksyushase
16.04.2022 00:31
Странице размещается 40 строк по 60 символов в каждой строке, а для хранения одного символа требуется 8 битов? !...
alinkass
16.04.2022 00:31
Решительно 1. дан четырехугольник со сторонами 15 и 20 см. найти его площадь и периметр. (записать данную тремя словесным, графический и на алгоритмическом языке) 2....
DUGLASMORFINI
25.04.2022 16:33
Написать программу, которая выводит на экран таблицу квадратов и кубов от 1 до n (n - вводится с клавиатуры)....
nazuli
19.12.2021 22:48
3. написать программу, которая вводит массив из n целых чисел и выводит на экран элементы с чётными номерами. протестировать программу на произвольных массивах размерностью...
ЮлияМедведева
19.12.2021 22:48
4. написать программу, которая вводит массив из n целых чисел и выводит на экран сам массив и сумму всех его элементов. протестировать программу на следующих массивах:...
AMAYA000
19.12.2021 22:48
Известны координаты трех точек. составить программу нахождения площади треугольника, построенного по этим точкам...
Supermopsmeni
08.12.2022 20:14
Определите значение переменной с после выполнения следующего фрагмента программы: x: = 2.5e+02; x: = x + 0.5e+02; y: = -x; c: = -2*y - x; 25...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
i, n, a, b, k:integer;
begin
k:=1;
readln(n, a, b);
for i:=1 to n do
readln(a[i]);
for i:=a to b do
if ((a[i] mod 3)=0) or ((a[i] mod 5)=0) then k:=k*a[i];
writeln(k);
readln;
end.