В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
guluamovalera
guluamovalera
06.02.2022 00:37 •  Информатика

Составить программу в паскале: найти наибольшее целое n такое что : a) 3n^4-730n< 5 b) e^n-1000ln*n< =10

Ответ:
Hikena
Hikena
05.07.2020 09:17
1) Если использовать последний Паскаль АВС, который умеет вычислять степень (Power), то вот вариант программы:
var
   n:integer;
   s:real; {вообще, он целый, но мой компилятор не пропускает, почему-то считает, что                 результат вычислений будет real}
begins:=0;
n:=1;
while s<5 do 
   begin
   s:=3*power(n,4)-730*n; {для старого Паскаля напиши так: s:=3*sqr(sqr(n))-730*n}
   n:=n+1
end;
writeln(n)
end.

2)
var n,s:real;
begin
s:=0;
n:=1;
while s<=10 do
   begin
   s:=exp(n)-1000*Ln(n);
   n:=n+1
   end;
writeln(n)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?