В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Дан целочисленный массив из 10 элементов.элементы массива могут принимать целые значения от -50 до 50.составить программу ,позволяющую найти и вывести сумму элементов массива которые кратны 7 и оканчиваются на 5 .гарантируется,что в исходном массиве есть хотя бы один такой элемент. на языке

Ответ:
Hikary134
Hikary134
01.10.2020 18:21
Const N=10;
TYPE Chisla = array [1..N] of integer;
var f: Chisla;
procedure IChisla (N: integer; var a: Chisla);
begin  for var i := 1 to N do a[i] := random(-50, 50);
end;
procedure OChisla(N: integer;a: Chisla);
begin 
 for var i := 1 to N do write(a[i]:5);
end;
function Sum (a:Chisla): integer;
begin
for var i:=1 to N do  
  if (a[i] mod 7 = 0) and (a[i] mod 10 = 5) then result:= result+f[i]; 
 end;
BeginI
Chisla (N, f);
OChisla (N, f);
writeln ('Вывести сумму', Sum(f));
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?