Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
maryana070803
27.02.2020 05:47 •
Информатика
"составьте программу вычисления суммы элементов от первого отрицательного и до конца" (pascal abc)
Ответ:
dashabar1208
03.07.2020 13:24
Var
mas:array[1..100] of integer;
i,n,sum:integer;
bool:boolean;
begin
bool:=false;
sum:=0;
readln(n);
for i:=1 to n do
begin
read(mas[i]);
if mas[i]<0 then
bool:=true;
if bool=true then
sum:=sum+mas[i];
end;
writeln(sum);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
sergey070707
03.04.2023 12:12
Дайте развернутое определение понятия множество ....
Nail20041
04.01.2020 17:06
Петя записал IP-адрес школьного сервера на листке бумаги и положил его в карман куртки. Петина мама случайно постирала куртку вместе с запиской. После стирки Петя обнаружил...
АртёмПестов
20.03.2023 23:01
Дано трёхзначное число. Если число кратно 3, то найти первую цифру числа, иначе вывести сумму первых двух цифр числа.№2.Определить, принадлежит ли точка A с координатами...
ДИЛЯ2002111
03.02.2023 18:01
Составить программу паскаль которая будет вычислять периметр и площадь прямоугольника. и программу которая будет вычислять косинус углов треугольника а,в,с...
Vftfg
03.02.2023 18:01
Составте программу,которая запрашивает 3 целых числа и,если одно из чисел не ровно нулю,выводит на экран их среднее арефметическое. pascale abc...
ирбиз
03.02.2023 18:01
Понять по информатике записать в развернутом виде число а16 = 3d,2e но при этом обьснить откуда какая цифра взята и как пришли к такому ! помимо ответа хотелось бы узнать...
AgeraClassik
03.09.2022 00:32
Послідовні цикл-це допоміжні алгоритми-...
Maykshmidt
04.10.2020 08:35
50 - встановіть відповідність між подання алгоритмів. 1. словесний б 2. формульно-словесний б 3. графічний б 4. програмний б 5. інш а) мова програмування delphi б) метод...
Желейка0Анжелька
21.03.2021 20:51
Здравствуйте с заданиями по информатике! 1. Составить программу нахождения минимального элемента и его номера в массиве вещественных чисел не более 50, задаваемых вводом...
viteralinap06rap
26.08.2022 16:00
Переведите числа в десятичную систему счисления. 222(в 6 степени счисления) 101011(в 2 степени счисления) буду с меня 15 : )...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
mas:array[1..100] of integer;
i,n,sum:integer;
bool:boolean;
begin
bool:=false;
sum:=0;
readln(n);
for i:=1 to n do
begin
read(mas[i]);
if mas[i]<0 then
bool:=true;
if bool=true then
sum:=sum+mas[i];
end;
writeln(sum);
end.