В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
QuAtTro271
QuAtTro271
18.03.2021 16:48 •  Информатика

Надо написать программу, которая "задумывает" число в диапазоне от 1 до 10 и предлагает пользователю угадать число за 5 попыток.

Ответ:
svitlanakost
svitlanakost
03.07.2020 12:03
(С подсказками, не надо - удали)
var r,ch,z: integer;
begin
Randomize;
r:=random(10)+1;
z:=5;
repeat
write('Отгадайте число от 1 до 10. У вас ',z,' попыток :');
readln(ch);
z:=z-1;
if z>0 then
begin
If ch<r then Writeln('Неправильно! Загаданное число больше.')
else If ch>r then Writeln('Неправильно! Загаданное число меньше.')
else writeln('Вы угадали!');
end
else Writeln('Попытки кончились!');
until (z=0)or(ch=r);
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?