Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
r79533240813
18.01.2020 14:01 •
Информатика
Написать программу, которая для трёхзначного числа, если оно четное, то возводит в квадрат, а если нечётное, то находит сумму цифр.
Ответ:
КЕКАke
03.07.2020 09:58
Var a:integer;
begin
readln(a);
if a mod 2 = 0 then writeln(a*a) else
writeln((a div 100) + (a mod 10) + ((a mod 100) div 10));
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
shamahuligam007
07.12.2022 14:10
Напечатать последовательность из n – натуральных чисел, образованную по следующему правилу: каждое число в последовательности, начиная с третьего, получается сложением двух...
Сяй
07.12.2022 14:10
Напишите на языке c++! создать массив размером 10 и запольнить его рандомными числами 1)вывести только четные числа 2)сравнить каких чисел больше( четных или нечетных)...
yakurnovanasta
01.06.2020 13:58
Найти количество четных чисел от 10 до 20...
kikesee
01.06.2020 13:58
Чтобы закрыть активный документ word, не закрывая окна программы, нужно:...
Vitas40
11.07.2020 17:11
На диске d: необходимо выполнить следующую последовательность действий: 1)создать каталог мин2)открыть каталог мин3)создать каталог 14)открыть каталог 15)создать каталог 116)подняться...
TToMoLLIHuK1
11.07.2020 17:11
Можно ли изменить кнопки в строке состояния?...
yli2220
11.07.2020 17:11
Исполнитель кузнечик умеет перемещаться по числовому лучу только вперед на 2 деления (в) или назад на три деления (н), а так-же он может закрашивать деление (з). таня написала...
Demo180
06.02.2022 14:25
Найти количество решений уравнения (a\/b)←→c/\d=0...
ivanova48
28.08.2021 08:19
На телефоне у никиты установлен пароль с числовым кодом. его можно разблокировать при наборе определённого четырёхзначного числа. сумма цифр этого кода – двухзначное число,...
polina359674
21.05.2021 06:55
Напишите программу для работы с массивом позволяющую 1)создать массив из 16 элементов целого типа, при описании количество элементов использовать именованную константу. 2)заполнить...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
begin
readln(a);
if a mod 2 = 0 then writeln(a*a) else
writeln((a div 100) + (a mod 10) + ((a mod 100) div 10));
end.