В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
polina359674
polina359674
21.05.2021 06:55 •  Информатика

Напишите программу для работы с массивом позволяющую 1)создать массив из 16 элементов целого типа, при описании количество элементов использовать именованную константу. 2)заполнить массив случайными числами, не превосходящими 20 3) вывести массив на экран в строку 4) подсчитать количество элементов, меньших 11

Ответ:
Fakla
Fakla
07.10.2020 13:02
Program NekitZor;
const
n=16;//1-Именованная переменная количество елементов 
var 
a:array[1..n] of integer;
k:integer;
i:integer;
begin
for i:=1 to n do
a[i]:=random(20);//2-Массив чисел, задал рандомно не больше 20
for i:=1 to n do write(a[i],'    ');//3-Вывел массив в строку
for i:=1 to n do 
if a[i]<11 then k:=k+1;//4-Подсчитал количество елементов меньше 11
writeln();
writeln();
writeln('Количество елементов меньше 11 = ',k);
end.

Напишите программу для работы с массивом позволяющую 1)создать массив из 16 элементов целого типа, п
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?