В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Lifeismyy
Lifeismyy
07.03.2022 03:26 •  Информатика

Напишите программу в паскале, которая получает три числа и выводит количество натуральных одинаковых чисел в этой цепочке. пример: введите три чила: 5 5 5 все числа одинаковые.

Ответ:
ged95
ged95
03.07.2020 06:25
Если в три переменные:
var a,b,c:integer;
begin
writeln ('Введите 3 числа');
read (a,b,c);
if (a=b)or (a=c) or (b=c) then
begin
if (a>1) and (b>1) and (c>1)and (a=b) and (a=c) and (b=c) then //Одно ненужное условие для наглядности
writeln ('Все числа одинаковые');
if ((a>1) and (b>1) and (a=b)) or ((a>1) and (c>1) and (a=c)) or ((b>1) and (c>1) and (b=c)) then writeln (2);
end
else writeln ('Нет одинаковых чисел');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?