В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Leoapps
Leoapps
10.08.2020 20:47 •  Информатика

Написать программу на языке pascal. суть заключается в выводе чисел в стандартном виде. например программа program n_1; var a: double; begin a: =1/100000000 end. при исполнении выводит 1e-08. а требуется вывод 0.00000001 решение конкретно данного случая не интересует, требуется программа для общего решения всех ситуаций. решение для других языков не предоставлять. требовалось бы для других - проблем бы не было.

Ответ:
lopkin
lopkin
09.10.2020 22:06

Просто пишите Writeln(a:10:5) и с форматного вывода получаете число в стандартном виде. Первое число отвечает за кол-во символов для записи переменной, а второе число отвечает за число символом после запятой

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?