Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
Элника
23.08.2022 21:42 •
Информатика
Напишите программу, которая выводит на экран таблицу умножения на n ( n-целое число в диапазоне от 2 до 10, вводимое с клавиатуры), паскаль.
Ответ:
NikaI004
02.07.2020 20:42
Вариант с проверкой правильности ввода
var
n, i: integer;
begin
n := 0;
while (n <= 1) or (n > 10) do
begin
write('Введите n в диапазоне от 2 до 10 = ');
readln(n);
end;
for i := 1 to 9 do
writeln(n, ' * ', i, ' = ', n * i);
end.
без проверки
var
n, i: integer;
begin
write('Введите n в диапазоне от 2 до 10 = ');
readln(n);
for i := 1 to 9 do
writeln(n, ' * ', i, ' = ', n * i);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
vasiaplaton
07.10.2021 11:36
Чему будет равно значение k после выполнения программы при n=65? Решите...
orehskonastia
19.08.2022 03:18
1. Для чего нужна формула? 2. Что отличает ввод формулы от текста? 3. Как формируется ссылка на ячейку? 4. Какие символы можно использовать для создания формулы? 5. Что...
raushanturlihan
15.03.2023 17:15
Число 1010=10102 в восьмиразрядном представлении имеет вид:...
софа336
16.01.2020 08:11
Составьте таблицу истинности для следующей логической функции: f=x& y x & y...
Zefirka08
16.01.2020 08:11
1. составить программу, которая формирует массив из 15 случайных чисел от -20 до 20 и четные числа возводит в квадрат. на экран выводятся исходные данные и преобразованные...
НИЗНАЙКА2006
16.01.2020 20:08
Символы, которые можно использовать для записи программы...
Slobodenyuk21
09.11.2022 07:29
Напишите программу для сложения двух однозначных чисел. паскаль. + блок-схему составить все если решите...
lliza123
09.11.2022 07:29
Дано целое трёхзначное число x. выведете число,полученное при прочтении этого числа справа налево . значение x ввести с клавиатуры...
1234567890640
09.11.2022 07:29
Выведите все двузначные числа, которые кратны 5 на языке паскаль через цикл repeat или while как в : условие n 100, т.е. n: =10...
ДаняКашин
09.11.2022 07:29
1. даны 3 числа (a,b,c).возвести в квадрат те,которые меньше 5 и в куб меньше 5 2 . даны 4 числа определить колличество отрицательных 3 . дано двухдверное число определить...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var
n, i: integer;
begin
n := 0;
while (n <= 1) or (n > 10) do
begin
write('Введите n в диапазоне от 2 до 10 = ');
readln(n);
end;
for i := 1 to 9 do
writeln(n, ' * ', i, ' = ', n * i);
end.
без проверки
var
n, i: integer;
begin
write('Введите n в диапазоне от 2 до 10 = ');
readln(n);
for i := 1 to 9 do
writeln(n, ' * ', i, ' = ', n * i);
end.