Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
Helenar2212
12.04.2022 08:31 •
Информатика
Тема: одномерные массивы, написать программу использую rite, riteln ; все элементы кратные трем делятся на три, остальные умножаются на 3.
Ответ:
andreymarshev0p0b1aa
02.07.2020 19:16
Const N=...;//указываешь количество элементов массива
var a:array [1..N] of integer;
i:integer;
begin
for i:=1 to N do
readln(a[i]);
for i:=1 to N do begin
if a[i] mod 3 =0 then a[i]:=a[i] div 3 else a[i]:=a[i]*3;
writeln(a[i]);
end;
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
FizTex
15.05.2023 15:32
Напишите прогу студент денис часто прогуливает свои пары в университете. сегодня, когда денис пришел в деканат, он узнал, что нужно за каждую пропущенную пару написать объяснительную....
Dinobot774
15.05.2023 15:32
Изменяя лишь одну букву в слове, востановить следующие ципочки слов ;...
LeraSmile12
15.05.2023 15:32
Учитель придумал пароль из 8 символов для каждого из 150 учеников, причем он использовал 26 латинских букв и 10 цифр. каждый символ кодируется минимальным кол-вом бит. найти...
GrootShkolnik
21.01.2023 18:09
Написать программу в python...
fenx73
17.01.2022 20:54
Написать функцию нахождения кол-ва цифр через рекурсию. паскаль. рекурсия. через функцию....
2004тигр2004
24.10.2022 04:20
Выпиши из предложений словосочетания, соответствующие схеме: прич. + сущ. (главное слово). Не меняй порядок слов, в котором они даны в предложении. (Не ставь запятую между...
osmaginh77
06.02.2022 11:41
Запиши цифрой (без точки в конце) количество букв в каждом слове, которые обозначают гласные звуки. Кобра...
ИЗЫДИ666
06.02.2022 11:41
Tom (not to have) breakfast yesterday...
965845484152
08.08.2021 17:13
Разложи на множители s²-2st+t²...
ОффниКим
16.03.2023 05:13
1. Чи належить графіку рівняння x-2y = 4 точка:а) А(1; 0); б) B(6; 1); в) C(2; 1); г) Р(6; 2)?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var a:array [1..N] of integer;
i:integer;
begin
for i:=1 to N do
readln(a[i]);
for i:=1 to N do begin
if a[i] mod 3 =0 then a[i]:=a[i] div 3 else a[i]:=a[i]*3;
writeln(a[i]);
end;
end.