В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
maksbaduk
maksbaduk
21.09.2020 16:38 •  Информатика

Написать программу с использованием цикла с постусловием рараметром и составит и блок схемы дано натуральное число определить количество его нечетеых делителей

Ответ:
LK2002
LK2002
03.10.2020 11:15
Program dividers;
var
    c,i,n :Integer;
begin
     readln(n);
     repeat
          if ( (n mod i) = 0 ) and ( (i mod 2) <> 0) then c:= c + 1;
          if  ( (n / i) mod 2) <> 0 then c:= c + 1;
          i:= i + 1;
     until i < (sqrt(n) + 1);
     writeln(c);
end.
   
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?