В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
alesia4
alesia4
19.08.2022 14:11 •  Информатика

Дано трехзначное число. напишите программу, которая определяет: а) есть ли среди цифр заданного целого трехзначного числа одинаковые пример входных данных: пример выходных данных: 123 нет 121 да 222 да

Ответ:
FACE091
FACE091
01.10.2020 16:06
Ну если я правильно понял то что тут написано то вот на pascal'e.. )
Var n,a,b,c:byte;
begin readln(n);
a:=n mod 10;
n:=n div 10;
b:=n mod 10;
n:=n div 10;
c:=n mod 10;
if (a=b) or (a=c) or(b=c) then writeln('да') else writeln('нет');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?