В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
kotflin
kotflin
28.02.2020 08:28 •  Информатика

Составить программу на паскале находящюю самое длинное слово в строке начинающееся на букву а , и выводящуюю количество букв в

Ответ:
drswag12312
drswag12312
24.05.2020 10:46

var s:string;
i,n,max:byte;

begin
n:=0;i:=1;max:=0;
write('Введите s -> ');readln(s);

while i<=length(s) do begin
if (i=1) or (s[i]=' ') then begin
if i <> 1 then inc(i);
if (i<=length(s))and((s[i]='a') or (s[i]='A')) then

while i<=length(s) do
if s[i]<>' ' then begin
inc(n);
inc(i);
end else break;
end;
inc(i);

if max<n then max:=n;
n:=0;
end;
write('Длина самаго длинного слова на букву A = ',max);
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?