В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
vitusyaischuk
vitusyaischuk
21.07.2022 13:50 •  Информатика

Составить программу, определяющую животное, соответствующее году по китайскому гороскопу

Ответ:
nastasyasaenko
nastasyasaenko
02.07.2020 06:55
var a, b, c, i:integer;
begin
   read (a);
   a:=a-4;
   if a = -3 then write ('Петух');
   if a = -2 then write ('Собака');
   if a = -1 then write ('Свинья');
   if a mod 12 = 0 then writeln ('Крыса');
   if a mod 12 = 1 then writeln ('Бык');
   if a mod 12 = 2 then writeln ('Тигр');
   if a mod 12 = 3 then writeln ('Кролик');
   if a mod 12 = 4 then writeln ('Дракон');
   if a mod 12 = 5 then writeln ('Змея');
   if a mod 12 = 6 then writeln ('Лошадь');
   if a mod 12 = 7 then writeln ('Овца');
   if a mod 12 = 8 then writeln ('Обезьяна');
   if a mod 12 = 9 then writeln ('Петух');
   if a mod 12 = 10 then writeln ('Собака');
   if a mod 12 = 11 then writeln ('Свинья');
end.
0,0(0 оценок)
Ответ:
nik22041
nik22041
02.07.2020 06:55
Program god_Japan;
var y, y1: Integer;
color : Integer;
beast : Integer;
begin
Write('Введите год');
ReadLn(year);
year1 := ((year - 1984) mod 60 + 60) mod 60;
beast := year1 mod  12;
color := (year1 div 12) mod 5; 
Write(year, ' - год ');
if beast in [2, 3, 4] then 
case color of 
0: Write('зеленого'); 
1: Write('красного'); 
2: Write('желтого'); 
3: Write('белого'); 
4: Write('черного'); 
end
else 
case color of   
0: Write('зеленой'); 
1: Write('красной'); 
2: Write('желтой');
3: Write('белой'); 
4: Write('черной'); 
end; 
Write(' ');
case beast of 
0: Write('Крысы');
1: Write('Коровы');
2: Write('Тигра'); 
3: Write('Зайца'); 
4: Write('Дракона'); 
5: Write('Змеи'); 
6: Write('Лошади');
7: Write('Овцы'); 
8: Write('Обезьяны'); 
9: Write('Курицы'); 
10: Write('Собаки'); 
11: Write('Свиньи'); 
end; 
WriteLn();
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?