В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ERTEND
ERTEND
14.03.2023 21:05 •  Информатика

1.написать программу, которая вычисляет частное двух чисел. программа должна проверять правильность введенных пользователем данных и, если они неверные (делитель равен нулю), вы давать сообщение об ошибке. ниже рекомендуемый вид экрана во время выполнения программы (данные, введенные пользователем, выделены полужирным шрифтом). вычисление частного. введите в одной строке делимое и делитель, затем нажмите . -> 12 о вы ошиблись. делитель не должен быть равен нулю.

Ответ:
shram070
shram070
02.07.2020 01:23
Program qq;
Var a, b, c:real;
Begin
Writeln('введите два числа');
Readln(a,b);
If b=0 then begin writeln('делитель не должен равняться нулю, введите числа повторно')
readln(a, b);
End
If else begin c:=a/b;
End
Writeln('получившееся число', c)
End.
Может где-нибудь есть косячок, но в основном, все должно получиться, удачи:)
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?