В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
30Космос03
30Космос03
20.09.2021 19:10 •  Информатика

Написать программу на c++ которая выводит пирамиду из чисел. с клавиатуры водится число и до этого числа строится пирамида. вот как должно выглядеть(пример)

Ответ:
yanastepina83
yanastepina83
11.09.2020 11:24

#include <iostream>

using namespace std;

int main()

{

 int n, i, j;

 string s, c;

 cout << "N = ";

 cin >> n;

 s = string(n, ' ');

 for (i = 1; i <= n; i++) {

   cout << "\n" << s;

   s.erase(s.size() - 1);

   for (j = 1; j <= i; j++) {

     if (n <= 9)

       c = " ";

     else

       c = i <= 9 ? "  " : " ";

     cout << c << i;

   }

 }

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?