В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ilonazelen
ilonazelen
11.01.2022 23:09 •  Информатика

Требовалось написать программу которая решает уравнение а|x|=b относительно х для любых чисел а и b, введенных с клавиатуры

Ответ:
NEADgff
NEADgff
01.07.2020 22:20
Var a,b:integer; x:real;
begin
readln (a,b);
x:=abs(b/a);
writeln (x:0:2);
end.

АБС это модуль, но я могу и ошибаться, тогда
var a,b:integer; x:real;
begin
readln (a,b);
If a<0 then a:=a*(-1);
If b<0 then b:=b*(-1);
x:=abs(b/a);
writeln (x:0:2);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?