В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
kozlovaangelina
kozlovaangelina
31.05.2020 15:57 •  Информатика

Разделить массив, заполненный случайным образом только положительными числами, на два - четных и нечетных. составить блок схему и написать программу.

Ответ:
korostelevaanap0a9d1
korostelevaanap0a9d1
30.06.2020 09:54
Uses crt;
const n=10;
var a,b,c: array [1..n] of integer;
    x,y,z,k: integer;
begin
     y:=0;
     z:=0;
     for x:=1 to n do begin
         a[x]:=random(100)+1;
         if a[x] mod 2=0 then begin
            inc(y);
            b[y]:=a[x];
            end
            else begin
                 inc(z);
                 c[z]:=a[x];
            end;
         write(a[x]:4);
     end;
     writeln;
     k:=y;
     for y:=1 to k do
         write(b[y]:4);
     writeln;
     k:=z;
     for z:=1 to k do
         write(c[z]:4);
end.
Разделить массив, заполненный случайным образом только положительными числами, на два - четных и неч
0,0(0 оценок)
Ответ:
kazybekabdrahman0707
kazybekabdrahman0707
30.06.2020 09:54
Program test;
var i,k,z:integer;
m:array[1..100] of integer;
c:array[1..100] of integer;
n:array[1..100] of integer;
begin
randomize;
for i:=1 to 10 do
begin
m[i]:=random(1000); 
if m[i] mod 2 =0  then 
begin 
k:=k+1; 
c[k]:=m[i]; 
end 
else 
begin  z:=z+1; 
n[z]:=m[i]; 
end;
end;
for i:=1 to z do
write('     НЕЧЕТНЫЕ',n[i]);
writeln();
writeln();
for i:=1 to k do
write('      ЧЕТНЫЕ',c[i]);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?