В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Sa4eR
Sa4eR
20.02.2023 07:51 •  Информатика

Написать программу в паскаль
Дан целочисленный массив размера NN, содержащий ровно два одинаковых элемента. Найти номера одинаковых элементов и вывести эти номера в порядке возрастания.

Ответ:
znikitai
znikitai
03.09.2020 17:27

Variant 1

var

 A: array[1..100] of integer;

 N, i, j: byte;

begin

 write('N = ');

 readln(N);

 for i := 1 to N do

 begin

   write('a[', i, '] = ');

   read(a[i])

 end;

 writeln;

 for i := 2 to N do

   for j := 1 to i - 1 do

     if a[i] = a[j] then begin

       writeln('Номера: ', j, ' и ', i);

       exit

     end;

 writeln

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?