В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ladybird1
ladybird1
16.05.2021 01:10 •  Информатика

Дан целочисленный двумерный массив 6x10. опишите на языке и на языке программирования паскаль алгоритм вычисления произведения минимальных элементов из каждой строки. напечатать значение этого произведения. предполагается, что в каждой строке минимальный элемент единственный.

Ответ:
Asilkhab5509
Asilkhab5509
30.06.2020 08:04
Ну в общих чертах проходиться по каждой строке массива, находить минимальный элемент и на него домножать результат.

uses crt;
const n=6;m=10;
var i,j,min,ans:integer;
a:array[1..n,1..m] of integer;
begin
ans:=1;
for i:=1 to n do
begin
for j:=1 to m do
begin
a[i,j]:=random(1,20);
write(a[i,j]:3);
end;
writeln;
end;
for i:=1 to n do
begin
min:=a[i,1];
for j:=2 to m do
if a[i,j]<min then
min:=a[i,j];
ans:=ans*min;
end;
writeln(ans);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?