В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
inkakanchiyp0706d
inkakanchiyp0706d
12.09.2021 12:39 •  Информатика

Pascal ABC Дана строка, состоящая из слов (разбитых пробелами) и строка символов. Необходимо выяснить, можно ли из символов строки 2 получить слова из строки 1. Если можно, то вывести эти слова, иначе вывести NO. (буквы из набора можно использовать несколько раз)
Входные данные
Строка содержащая слова через пробел и строка с набором букв
Выходные данные
Слова, которые можно получить из символов второй строки или слово NO
Для примера:

Ввод
hello i love you
ieohuyvl
Результат
hello
i
love
you

Ответ:
RezinkaLIVE
RezinkaLIVE
21.02.2022 01:33

var slova, bukvy, slovo : string;

   i, b, k, c, j, l, kolvo, dlina1, dlina2 : integer;

   a : array[1..50] of string;

begin

 Writeln('Введите слова');

 Readln(slova);

 Writeln('Введите буквы');

 Readln(bukvy);

 dlina1 := length(slova);

 dlina2 := length(bukvy);

 k := 1;

 for i := 1 to dlina1 do

   if slova[i] = ' ' then

     k := k + 1;

 writeln(k);

b := 1;

i := 1;

while i <= length(slova) do

begin

 if (slova[i] <> ' ') and (i <> length(slova)) then

   slovo := slovo + slova[i]

 else

 begin

   a[b] := slovo;

   slovo := '';

   b := b + 1;

 end;

i := i + 1;

end;

a[k] := a[k] + slova[length(slova)];

b := 0;

l := 0;

for i := 1 to 50 do

 if a[i] <> '' then

   begin

   slovo := a[i];

   for k := 1 to length(slovo) do

     for c := 1 to length(bukvy) do

       if slovo[k] = bukvy[c] then

         j := j + 1;

   if j = length(slovo) then

   begin

     writeln(slovo);

     l := l + 1;

     j := 0;

   end;

   end;

if l = 0 then

 writeln('NO');

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?