В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
дитус
дитус
31.12.2020 10:12 •  Информатика

НАПИШИТЕ ПРОГРАММЫ ДЛЯ ПИТОНА! 1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 7. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Программа должна вывести числа, количество чисел, кратных 7.
2.Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 7. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Программа должна вывести сумму чисел, кратных 7.

Ответ:
МашаКотик2004
МашаКотик2004
07.02.2022 17:15

1)

c = 0

while True:

   a = int(input())

   if a == 0:

       break

   if a % 7 == 0:

       c += 1

print(c)

2)

sum = 0

while True:

   a = int(input())

   if a == 0:

       break

   if a % 7 == 0:

       sum += a

print(sum)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?