В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Аделя0504
Аделя0504
11.01.2020 11:27 •  Информатика

По паскалю. 1. написать программу, которая вводит последовательность вещественных чисел, состоящую из n элементов, и определяет, является ли эта последовательность возрастающей. 2. дан целочисленный массив размерности n. необходимо "сжать" массив, выбросив из него каждый второй элемент. дополнительный массив использовать нельзя.

Ответ:
sofa287
sofa287
27.05.2020 17:51

var a:array[1..1000]of longint;
n,i,kol:longint;
begin
read(n);
for i:=1 to n do
read(a[i]);
for i:=1 to n-1 do
if a[i]<a[i+1] then kol:=kol+1;
if kol=n then write('vorast') else writeln('net');
end.

 

 

var a:array[1..1000]of longint;
n,i:longint;
begin
read(n);
for i:=1 to n do
read(a[i]);
for i:=1 to n do
if i mod 2 <>0 then write(a[i],' ');
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?