Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
Ооооооокккккккк
20.03.2022 04:46 •
Информатика
15.в заданном массиве вещественных чисел определить количество элементов меньших среднего арифметического значения.
Ответ:
mashtaleroksana
25.06.2020 15:36
Uses crt;
const N=30;
var a:array [1..N] of integer;
i,sum,k:integer;
sr:real;
begin
for i:=1 to N do
begin
readln(a[i]);
sum:=sum+a[i];
end;
sr:=sum/N;
for i:=1 to N do
if a[i]<sr then inc(k);
writeln(k);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
innabat1
18.03.2021 14:46
Вопросы по информатике как на ваш взгляд, удобнее копировать и перемещать файлы: через контекстное меню или перетаскивая их мышью? сравните разные точки зрения.2.какие выделения...
UTOYKA228
31.03.2020 16:51
По введённому числу n вычислить n! =1*2*3**n...
rambobamborap08ffj
20.03.2023 01:44
Напечатать 10 раз столбиком и 5 раз строкой слово komp в паскале...
protasovarsenip0a3kn
13.04.2020 15:42
Определите объём 16-цветного рисунка, с размерами 128х200....
dhristenko8
13.04.2020 15:42
Одно слово содержит 2.5 байт информации, а другое 25 бит. на сколько букв одно слово длиннее другого?...
dina53646
13.04.2020 15:42
Вася вводит число,нажимая клавиши 3 , 2 и 1 .какие операции должен выполнить компьютер,чтобы соответствующее число было записано в память?...
Ева12а
18.08.2022 10:34
Напишите программу для решения следующей дано целое число является ли оно четным?...
25000h
02.04.2022 16:52
Сколькими двоичными цифрами можно закодировать оценки учащихся? (“2”, “3”, “4”, “5”)? a) 1 b) 2 c) 3 d) 4...
uchikha2016
28.12.2020 14:10
. Рассчитать, какое количество страниц простого текста можно охранить на дискете при заданных размерах страницы. На одну страницу помещается 32 строки по 64 символа в каждой...
Viper397
07.06.2023 06:03
Де відбуваються мутації що передаються наступним поколінням...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
const N=30;
var a:array [1..N] of integer;
i,sum,k:integer;
sr:real;
begin
for i:=1 to N do
begin
readln(a[i]);
sum:=sum+a[i];
end;
sr:=sum/N;
for i:=1 to N do
if a[i]<sr then inc(k);
writeln(k);
end.