Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
pikachu7bitch
02.07.2021 10:58 •
Информатика
Взаданном массиве вещественных чисел определить количество элементов меньших среднего арифметического значения.
Ответ:
Enotlk1337
15.05.2020 22:26
CONST N=5;
var
x:real;
i:integer;
ar:array[1..N] of real;
begin
for i:=1 to N do begin
readln(ar[i]);
x:=x+ar[i];
end;
x:=x/i;
for i:=1 to N do if (ar[i] < x) then write(ar[i],' ');
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
saruchanyan777
06.03.2021 23:38
Решить по информатике n=6mod6+1 n-?...
Molodoy186
28.10.2021 01:00
На языке паскаль составьте программу вывода на экран номера этажа и номеров квартир ,находящихся на данном этаже,девятиэтажного дома ,на каждом этаже которого находится по...
konulrzayevaa
02.07.2020 23:01
Пример информации в текстовой форме, числовой и графической....
Дима51497
22.05.2020 10:36
1. составить программу нахождения для заданного натурального числа всех делителей, заканчивающихся на цифру 5 или 2...
25000h
22.05.2020 10:36
2. найти кол-во нечетных цифр в записи числа n...
impalaSam
22.05.2020 10:36
3. вывести все двузначные числа , у которых старшая сумма в два раза больше младшей...
Маринетт1210
10.08.2020 16:43
Работа в питоне даны катеты прямоугольного треугольника.найдите его периметр и площадь...
nikita228wwx
12.01.2021 11:10
1)дано двухзначное число m получить n образовавшим вписование цыфры 1 между цифрами 65 и 615 2) дано трехзначное число n получить m заменяя на 0 средние цифры 81 и 851 3)...
слмтл
12.01.2021 11:10
Сообщение весит 64 бит в нем 8 символов. сколько символов в алфавите? напишите с ответом...
KennyPro
06.09.2021 04:54
Составьте программу для нахождения куба числа если оно положительное...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var
x:real;
i:integer;
ar:array[1..N] of real;
begin
for i:=1 to N do begin
readln(ar[i]);
x:=x+ar[i];
end;
x:=x/i;
for i:=1 to N do if (ar[i] < x) then write(ar[i],' ');
end.