В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Aleksandra1111117
Aleksandra1111117
16.06.2020 13:05 •  Информатика

Написать программу: Дан одномерный массив С[100], заполненный числами из диапазона от -26 до 15. Написать программу, которая будет находить сумму элементов массива, стоящих на нечетных местах ЗАВТРА КРАЙ СДАТЬ

Ответ:
ydaschamp
ydaschamp
29.11.2021 18:50

program Prog;

var c: array[1..100] of Integer;

summ, i: Integer;

begin

randomize;

// заполнение

for i := 1 to 100 do

 c[i]:=random(42)-26;

// вывод массива

write('Массив: ');

for i := 1 to 100 do

 write(c[i],' ');

// вычисление суммы элементов на нечетных местах

for i := 1 to 100 do

 if ((i mod 2) = 1) then

  summ+=c[i];

writeln;

// вывод этой суммы

write('Сумма элементов на нечетных местах: ');

write(summ);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?