В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
1234мика
1234мика
10.04.2020 18:30 •  Информатика

Требовалось написать программу вычисления факториала числа n (факториал числа n есть произведение всех целых чисел от 1до n ). Программист торопился и написал программу неправильно. Ниже приведён фрагмент его программы, в котором содержится четыре ошибки: k = 1
f = 0
while k < n :
f = f * k
k + = 1
Найдите ошибки. Допишите необходимые операторы. Программа python.

Ответ:
arladich
arladich
25.11.2021 15:20

def fact(n: int) -> int:

   return 1 if (n==1 or n==0) else n * fact(n - 1)

print(fact(3))

num = int(input("n: " ))

factorial = 1

if num < 0:

  print("Минусовое число!")

elif num == 0:

  print("Факториал 0 это 1")

else:

  for i in range(1, num + 1):

      factorial = factorial*i

  print("Факториал от",num,"это",factorial)

Объяснение:

как по мне первый вариант намного лучше, но я на всякий случай сделал 2


Требовалось написать программу вычисления факториала числа n (факториал числа n есть произведение вс
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?