В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Gklunnyy123
Gklunnyy123
23.11.2022 19:55 •  Информатика

Как написать программу для паскаля которая считает площадь

Ответ:
ivankarmashov2p01nx6
ivankarmashov2p01nx6
25.06.2020 07:30
Квадрат вписан в круг. 
Нужно написать програмку, которая считает площадь окружности, если ввести сторону квадрата 

У меня вышла формула : 

S окр = ((a^2)/2) * (P(число пи)-2) - Площадь круга минус площадь квадрата 

вот код : 

Program Okruzhnost; 
Var 
x,y: real; 
S: real; 

Procedure RectS(a,b: real; Var S:real); 
Begin 
S := (((sqr(x))/2) * (pi-2)); 
end; 

Begin 
WriteLn('Введите сторону квадрата'); 
ReadLn(x,y); 
RectS(x,y,S); 
WriteLn('Площадь окружноси равна',S); 

end.
Как написать программу для паскаля которая считает площадь
0,0(0 оценок)
Ответ:
MaXD1337
MaXD1337
25.06.2020 07:30
Var a,S:integer;
Begin
 writeln('введите сторону квадрата');
 readln(a);
 S:=a*a;
writeln('Площадь = ',S);
readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?