В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
FSoxGy
FSoxGy
27.01.2023 14:19 •  Информатика

Дано: массив целых чисел a[n].проверьте, есть ли в нем отрицательные элементы.если есть, найдите наибольшее i, при котором a[i]< 0, иначе выведите сообщение. напишите программу для паскаль или лазарус

Ответ:
2katena
2katena
24.06.2020 20:52
Program gt;
var a:array[1..1000]of integer;
i,n,l:integer;
begin
read(n);
l:=0;
for i:=1 to n do
begin
read(a[i]);
if(a[i]<0)then l:=i;
end;
if(l=0)then writeln('НЕТ ОТРИЦА... В массиве')else writeln(l);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?