В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
nikols7
nikols7
13.03.2020 18:51 •  Информатика

Decimal to Binary На вход программе подается натуральное число, записанное в десятичной системе счисления. Напишите программу, которая переводит данное число в двоичную систему счисления. Формат входных данных На вход программе подается одно натуральное число. Формат выходных данных Программа должна вывести число записанное в двоичной системе счисления. Тестовые данные green_circle Sample Input 1: 5 Sample Output 1: 101 Sample Input 2: 128 Sample Output 2: 10000000 Питон

Ответ:
anognev
anognev
18.10.2021 13:50

Программа:

n = int(input('Введите натуральное число (в 10-й СС): '))

k = ''

while n > 0:

   i = str(n % 2)

   n = int(n / 2)

   k = i + k

print(k)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?