В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
korolnn
korolnn
31.07.2022 17:55 •  Информатика

Составьте программу нахождения наибольшего общего делителя для двух чисел. (воспользоваться алгоритмом евклида). алгоритм евклида поиска наибольшего общего делителя двух чисел: вычитай из большего меньшее, пока числа не станут равны. полученное значение и будет искомым.

Ответ:
mpaxomow
mpaxomow
24.06.2020 16:25
Var  a, b: word;
function NOD(x, y: integer):integer;
begin 
repeat    
 if abs(x) > abs(y) then      
 x := x mod y    
else    
  y := y mod x;  
until (x = 0) or (y = 0); 
  NOD := abs(x + y);
 end;
begin 
 write('a=');read(a);  
 write('b=');readln(b); 
writeln('NOD(a,b)=', NOD(a, b)); 
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?